Service Issues in US Cloud
Incident Report for Mitel CloudLink
Resolved
We are no longer seeing any issues and service has been healthy for the past 30 minutes. Confirmed with our downstream provider that there was an interruption to service that impacted the CDN we use to cache the web applications, and the impact lasted for approximately 40 minutes between 9:37 AM and 10:13 AM PDT.
Posted Jul 18, 2023 - 14:05 EDT
Monitoring
Our downstream provider has updated that service is being restored and we can see that our web applications are now responding again. We have seen stable service for the past 15 minutes so we are moving this incident to monitoring.
Posted Jul 18, 2023 - 13:26 EDT
Investigating
We are aware of issues with our downstream provider impacting service to our US cloud. We are currently engaged and working on resolution and will provide further updates when we have more details. The issue appears to be isolated to web applications while our REST APIs are still working, but we will continue to monitor while our downstream provider is working on this issue.
Posted Jul 18, 2023 - 12:50 EDT
This incident affected: CloudLink Authentication Portal, CloudLink Accounts Portal, CloudLink Gateway Portal, Mitel One, and MiTeam Meetings.