Service Issues in US Cloud
Incident Report for Mitel CloudLink
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 18:04 EDT
Monitoring
Our downstream provider has updated that service is being restored and we can see that our API's are now responding again. We have seen stable service for the past 15 minutes so we are moving this incident to monitoring.
Posted Jun 13, 2023 - 16:50 EDT
Update
We're still getting regular updates from our downstream provider that they are working to resolve the issue, but service has not yet been restored. We continue to monitor.
Posted Jun 13, 2023 - 16:08 EDT
Update
All applications running on our US cloud will not be able to authenticate or make API calls to the platform. Our downstream provider has acknowledged the issue and is working to resolve as quickly as they can.
Posted Jun 13, 2023 - 15:28 EDT
Identified
We are aware of issues with our downstream provider impacting service to our US cloud. We are currently engaged and working on resolution and will provide further updates when we have more details.
Posted Jun 13, 2023 - 14:50 EDT
This incident affected: CloudLink Services (US) (Authentication) and CloudLink Authentication Portal, CloudLink Accounts Portal, CloudLink Gateway Portal, Mitel One, MiTeam Meetings.