CloudLink Gateway Connection Issues
Incident Report for Mitel CloudLink
Resolved
The cause of the issue was due to errors being detected in the Customers Gateway Database for the Softphone tables which led to the Gateway restarting and not reconnecting. Not all Gateways were receiving this error hence why it did not affect everyone.

Design were able to reproduce the issue by injecting those database errors in their lab environments, this allowed us to prove the fix before deploying.

The fix was to be more robust to those database errors.
Posted Jul 31, 2023 - 08:56 EDT
Update
A fix for the issue has been deployed earlier today and we continue to monitor.

For gateways that have been affected by this issue, rebooting the gateway will ensure the fix is automatically downloaded and installed. (This may take up to 20 minutes)

Remaining gateways will be upgraded in line with the Auto Update Schedule if enabled on the CloudLink Account.

If you are still experiencing issues after the reboot or Auto Update, then please contact Mitel via TechCentral Tracker so we can investigate further.
Posted Jul 07, 2023 - 11:17 EDT
Update
We continue to investigate each report on an individual basis and still require customers that are experiencing the issue to contact Mitel via our Tech Central Tracker.

We have identified an issue that we believe is the underlying root cause and are currently working on a resolution. Recovering Gateways in this condition would still need assistance from Mitel Product Support and we will require remote access to do so.
Posted Jul 06, 2023 - 08:26 EDT
Monitoring
We have seen a small increase in the influx of tickets stating the CloudLink Gateways are reporting connection issues and we are continuing to investigate these reports on an individual basis.

If your customer experiences issues with the CloudLink Gateway not connecting, then please do not factory reset as this could result in further issues. Please contact Mitel via TechCentral Tracker to assist us in identifying the issue and any trends. We will offer a further update if an underlying issue is detected and will also offer method of recovery.
Posted Jul 05, 2023 - 08:26 EDT