Mitel One 'Unknown' Calls on iOS Devices
Incident Report for Mitel CloudLink
Resolved
This incident has been resolved.

The issue was caused by a defect in the pervious version of the application which is now fixed in the 6.1.5 version currently available on the Apple App Store.
Posted Aug 03, 2023 - 10:07 EDT
Monitoring
Mitel One Mobile 6.1.5 has been released for iOS devices, which contains the fix for this issue. Please update the application through the Apple App Store to apply the fix to your device.
Posted Aug 01, 2023 - 07:57 EDT
Update
A resolution has been developed and is currently in test.
Posted Jul 31, 2023 - 09:47 EDT
Identified
We have identified the issue and are currently working on a fix.
Posted Jul 28, 2023 - 10:38 EDT
Investigating
We are currently investigating reports of users experiencing phantom 'Unknown' calls on Mitel One with iOS devices.

Rebooting the device when you have an 'Unknown' call may alleviate further instances whilst we continue to work on a resolution.
Posted Jul 27, 2023 - 09:29 EDT
This incident affected: Mitel One.