Calls not working on EU Cloud

Incident Report for Mitel CloudLink

Resolved

This incident has been resolved.
Posted Feb 17, 2021 - 09:16 EST

Monitoring

We have found and corrected the issue and service should now be restored. Will continue monitoring for a while before closing off this issue.
Posted Feb 17, 2021 - 04:14 EST

Investigating

We are currently investigating an issue which is preventing calls being made from Mitel Office Mobile Application and Mitel Office Web Application. Further status updates will follow.
Posted Feb 17, 2021 - 03:33 EST
This incident affected: CloudLink Services (EU) (Media).