Authentication Issues
Incident Report for Mitel CloudLink
Resolved
This incident has been resolved.
Posted Jun 13, 2022 - 15:05 EDT
Monitoring
We have implemented a fix for all regions and testing shows everything working.

Please note that there may be some caching occurring so if you encounter an error please wait a minute and try again. You may need to quit and restart any applications that have been open during this event.

We will continue to monitor for the next few hours.
Posted Jun 13, 2022 - 12:33 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 13, 2022 - 12:03 EDT
Identified
We have identified the issue and are working on a fix now. This issue affects all users authenticating with the CloudLink platform. Some users may see it working now while others may not. Will update again once we confirm it is working for all users.
Posted Jun 13, 2022 - 11:01 EDT
Update
We are also seeing a higher error rate in the US region.
Posted Jun 13, 2022 - 10:20 EDT
Investigating
We're currently investigating a higher than normal error rate with the authentication service in the EU region.
Posted Jun 13, 2022 - 10:12 EDT
This incident affected: CloudLink Services (US) (Authentication) and CloudLink Services (EU) (Authentication).