Calling Delays in EU
Incident Report for Mitel CloudLink
Resolved
This incident has been resolved.
Posted Nov 23, 2021 - 09:07 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 23, 2021 - 06:22 EST
Investigating
We are receiving reports of calling delays in EU where it takes up to 30 seconds for a call to ring at the other end. We are currently investigating.
Posted Nov 23, 2021 - 04:55 EST
This incident affected: CloudLink Services (EU) (Media).