CloudLink Daemon Service Disruption for MCX/MiCC

Incident Report for Mitel CloudLink

Resolved

Root cause:

The update on March 23/24 wasn’t successful and left the Windows service “Mitel CloudLink Daemon” on MiCC-B systems in a stopped state.
Posted Mar 25, 2026 - 07:30 EDT

Update

We are continuing to monitor for any further issues.
Posted Mar 24, 2026 - 09:22 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2026 - 06:32 EDT

Identified

Mitel Cloudlink Daemon has been rolled back to version 1.8.66+139. Please start Mitel Cloudlink Daemon service in the affected MiCC-B/MCX.
Posted Mar 24, 2026 - 06:23 EDT

Investigating

We are currently experiencing an issue where the CloudLink Daemon service is down for MCX/MiCC. Our engineering team has been engaged and is actively investigating it.
Posted Mar 24, 2026 - 05:23 EDT
This incident affected: CloudLink Services (EU) (Tunnel).