Elevated Error Rate on Notification Service in EU

Incident Report for Mitel CloudLink

Resolved

The issue was caused by an unexpected, rapid spike in traffic. This surge exceeded our service capacity, resulting in a temporary service disruption.
Posted Mar 04, 2026 - 16:16 EST

Monitoring

Service has been restored, we will continue to monitor
Posted Mar 04, 2026 - 12:36 EST

Investigating

We are aware of an elevated error rate on the Notification service in EU and are currently investigating. At this time it appears to be impacting Workflow and Microsoft Teams presence sync.

As of 10:41 EST we are seeing the services recover. We are continuing our investigation to identify the root cause.
Posted Mar 04, 2026 - 10:08 EST
This incident affected: CloudLink Services (EU) (Notifications).