Mitel One Availability on Google Play Store
Incident Report for Mitel CloudLink
Resolved
This incident has been resolved.
Posted Dec 08, 2022 - 16:34 EST
Monitoring
Please be aware that we have recognized that Mitel One Mobile is no longer found on the Google App Store.
At this time, we are working with the Google Store to understand why it is currently unavailable and will report back once more information becomes available.

This does not affect iOS devices
Posted Dec 08, 2022 - 08:17 EST