Issue with Tunnel service causing connection errors

Incident Report for Mitel CloudLink

Resolved

We experienced a temporary capacity issue that affected service availability during periods of high demand. The issue has been resolved, and additional safeguards have been put in place to prevent recurrence.
Posted Mar 23, 2026 - 09:30 EDT

Monitoring

The service has been restored and we will continue to monitor.
Posted Mar 20, 2026 - 18:09 EDT

Identified

The root cause has been identified, and our team is actively working on a resolution.
Posted Mar 20, 2026 - 15:50 EDT

Investigating

We are aware of issues in the Tunnel service and are currently investigating.
Posted Mar 20, 2026 - 13:39 EDT
This incident affected: CloudLink Services (US) (Tunnel).