Media delays in the EU

Incident Report for Mitel CloudLink

Resolved

The issue with the downstream provider is fully resolved now and we can confirm we no longer show any impact to any of our services.
Posted Sep 03, 2026 - 16:16 EDT

Investigating

We are aware of an issue with one of our downstream providers that is affecting Media in the EU. We are investigating and will update accordingly.
Posted Sep 03, 2026 - 12:29 EDT
This incident affected: CloudLink Services (EU) (Media).