Inbound Calls are not Ringing iOS Devices
Incident Report for Mitel CloudLink
Resolved
This incident has been resolved.

A feature was implemented to inform the Mitel One Web application that active calls are no longer ringing. Since the mobile app did not handle the new notification, iOS began to take actions against the mobile app. To fix this we changed the code so it no longer affected iOS.
Posted Oct 26, 2023 - 10:13 EDT
Monitoring
A fix has been deployed and we will continue to monitor.

Should you continue to have issues please uninstall, then reinstall the Mitel One Mobile application and this will resolve the issue.
Posted Oct 17, 2023 - 13:56 EDT
Identified
We have identified the issue and are currently working on a fix. This issue is not unique to iOS 17 as first reported.
Posted Oct 17, 2023 - 10:32 EDT
Investigating
We are currently investigating reports of Mitel One Mobile not notifying users of inbound calls with iOS 17, when the device is locked or the application put to the background.
Posted Oct 13, 2023 - 08:00 EDT
This incident affected: Mitel One.