Unable to log in to Mitel One Mobile on iOS after upgrading to 6.8.1

Incident Report for Mitel CloudLink

Resolved

The incorrect authentication URL was mistakenly used in version 6.8.1, this was corrected in version 6.8.2.
Posted Aug 08, 2025 - 16:23 EDT

Monitoring

The fix has been released in iOS version 6.8.2 of Mitel One.
Posted Aug 08, 2025 - 07:31 EDT

Identified

We have identified the issue and are working on a fix.
Posted Aug 08, 2025 - 06:53 EDT

Investigating

Currently there is an issue with the authentication in the iOS version of Mitel One version 6.8.1.
Please DO NOT UPGRADE to this build, a new build will be released as soon as possible that will fix this issue.
A further update to this will be posted once this new build is available.
Posted Aug 08, 2025 - 06:31 EDT
This incident affected: Mitel One.