OfficeLink Users Experiencing "Invalid Login Credentials" Error Message
Incident Report for Mitel
Resolved
User logins are behaving normally.
Posted 5 months ago. Apr 04, 2018 - 14:36 EDT
Monitoring
This issue has been resolved and we are currently monitoring user login events for errors.
Posted 5 months ago. Apr 04, 2018 - 10:29 EDT
Identified
Some users logging in to the OfficeLink application may experience an "Invalid Login Credentials" message even though their credentials are valid.

We are aware of this issue and are working on a resolution.
Posted 5 months ago. Apr 04, 2018 - 10:11 EDT