Accounts Console unresponsive
Incident Report for Mitel CloudLink
Resolved
This incident has been resolved.
Posted May 18, 2022 - 08:45 EDT
Monitoring
A fix has been implemented. You may need to clear your browser cache for accounts.mitel.io and log in before accounts load correctly.
Posted May 17, 2022 - 05:49 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 17, 2022 - 05:44 EDT
Update
We are continuing to investigate this issue.
Posted May 17, 2022 - 04:45 EDT
Investigating
We are currently investigating reports with the Accounts Console not being able to fetch account information.
Posted May 17, 2022 - 04:26 EDT
This incident affected: CloudLink Accounts Portal.