Video Conferencing Services Unavailable
Incident Report for Mitel CloudLink
Resolved
This outage has been resolved and service has been restored.
Posted Jan 15, 2020 - 19:00 EST
Identified
Our downstream provider has identified the root cause of the issue and indicated that a fix is underway. Some users may be able to use Video Conferencing services again as service is slowly being restored.

We will update this incident again once service has been fully restored.
Posted Jan 15, 2020 - 16:41 EST
Investigating
We are currently experiencing an outage with our Video Conferencing services which is affecting the MiTeam Meetings application. Our downstream provider has been made aware and is currently working on a resolution.

We will update this incident with more information as it becomes available.
Posted Jan 15, 2020 - 15:39 EST
This incident affected: CloudLink Services (EU) (Media) and CloudLink Services (US) (Media).