CloudLink Logins from Mitel Connect Failing
Incident Report for Mitel
Resolved
This issue has been resolved. If you continue to experience issues using the CloudLink Portal link in mitel Connect, please contact support.
Posted 4 months ago. Feb 14, 2018 - 19:04 EST
Identified
We're currently experiencing issues when attempting to reach the CloudLink portal when browsing from the Mitel Connect partner portal.

You can reach the portal directly by browsing to https://mitel.io/cloudlink/gateway/

The issue is expected to be resolved before 8PM Eastern Standard Time.
Posted 4 months ago. Feb 14, 2018 - 19:01 EST