Dial-in for MiTeam Meetings
Incident Report for Mitel CloudLink
Resolved
This incident has been resolved.
Posted Aug 06, 2020 - 11:08 EDT
Monitoring
We have received reports that some dial-in numbers for MiTeam Meetings are not able to connect. These calling issues are related to network congestion. Telecom providers acknowledged their networks are experiencing higher-than-normal traffic during the COVID-19 crisis.

We recommend the following:

• Use web audio as much as possible
• Dial in to the conference early if possible
• Attempt the call again or try a different dial-in number
• Plan meetings off the top of the hour (i.e. 1:15) or half hour (i.e. 1:45) to avoid the most congested times
Posted Apr 01, 2020 - 08:00 EDT